.

Browser compatibility changes to comply with PCI mandate

The Payment Card Industry Security Standards Council (PCI SSC) has mandated that all credit card processors must retire version 1.0 of an encryption method called TLS (Transport Layer Security).

To comply with this directive, and ensure the highest standards of security and data integrity, Wild Apricot will stop supporting TLS versions 1.0 and 1.1 on March 12, 2018, but will continue to support TLS version 1.2. However, some older browser versions do not support TLS 1.2, so visitors to your Wild Apricot site may have to upgrade their browsers if they want to make payments on your site.

To view a list of browsers versions that support TLS 1.2 and higher, see https://support.wildapricot.com/hc/en-us/articles/360000599828-Browser-compatibility-changes-to-comply-with-PCI-mandate

You should encourage visitors to your site to check their browser version against this table.

2 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    AdminTeam Support (Customer support, Wild Apricot by Personify) shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    0 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...

      Feedback and Knowledge Base